top of page

MaPS Group

Public·8 members

Driver WCH PCI Express >DUAL SERIAL for Windows 10 64-bit: FAQs and Troubleshooting - PC Help

this is the driver for wch pci expressdual serial for win 10 64 bit. or you can download the driver from the link which is in the description, or you can follow the instruction as below. installing the driver 1. unzip the downloaded folder into a temporary or regular directory. 2. double-click the ch38xdrc.sys file to start the driver installation 3. follow the on-screen instructions 4. finish the driver installation

Driver WCH PCI Express >DUAL SERIAL for Windows 10 64-bit

this page shows pci expressdual serial port card that sold by wch company. wch is a famous company for its desktop series motherboards, such as biostar ma10, ma11, ma14, ma24, ma45, etc. wch designed its pci express dual serial card with wch chipset to replace the old serial port and add 4 serial port in a pci-e slot, while reducing the load to the cpu by as much as 48% over conventional serial cards. original packing included 1x 2 port pcie serial card 1x 120mm standard height pci-e bracket 1x cd driver (adapter's chip number:.ch38x. if cant use cd to install the driver, pls contact us directly via the order page contact seller button or search ch38x and download the driver on the wch-ic website (ch38xdrv.exe)

i have a error saying that the driver is for windows 7, it should run in windows xp. i have the drivers for windows 7, but the interface is not compatible. i have done some research and heard that windows 7 running in xp, and xp running in windows 7 are not best practices and should never happen. how to get around the problem?

it worked fine for 4 months, everything was good, and today i noticed that the driver was working incorrectly at the serial port. i had to update the drivers as it wouldn't load into the software when i tried to load. so i got into the device manager and tried to uninstall and reinstall as i was told to do. it would not allow me to but could not figure out why, so i shut it down and restarted it to run through the test things i was told to do to troubleshoot it, so i get to it and it will not even come up in the devices and up all of the way to the device manager. help!!!!!! i am at my wits end and have been since it stopped working yesterday.

Group Page: Groups_SingleGroup
bottom of page